What is procedure to configure Mirror rootvg in HP-UX?

Answers were Sorted based on User's Feedback



What is procedure to configure Mirror rootvg in HP-UX?..

Answer / raghav

Perform Disk scan
#ioscan -funC disk
and choose the disk that is similar or bigger than the
primary disk partition
Create a physical bootable disk
#pvcreate -B /dev/rdsk/c0t3d0 (example)
Extend the primary vg [generally vg00]
#vgextend /dev/vg00 /dev/dsk/c0t3d0
Define configuration in boot LIF
#mkboot /dev/rdsk/c0t3d0
#mkboot -a "hpux -lq" /dev/rdsk/c0t3d0 --> to disable
Quorum
Mirror all LV to new disk
#vgdisplay -v vg00 |grep "LV Name" |awk '{print $NF}'
|while read line
>do
>lvextend -m 1$line /dev/dsk/c0t3d0
>done
Re-establish the location of boot, root, swap and dump
#lvlnboot -r /dev/vg00/lvol3
#lvlnboot -b /dev/vg00/lvol1
#lvlnboot -s /dev/vg00/lvol2
#lvlnboot -d /dev/vg00/lvol2
Add boot disk into file to ensure that when software is
installed the content of boot LIF of both disk will be
updated.
#vi /stand/bootconf
1 /dev/dsk/c0t3d0
:wq!
Hope this Helps you

Is This Answer Correct ?    2 Yes 0 No

What is procedure to configure Mirror rootvg in HP-UX?..

Answer / srinu babu

1. step is create the BDRA(Boot disk Reserved area)on a disk to be used as a mirrored of the boot-able disk.
#pvcreate -fB /dev/rdsk/c2t6d0
Created an LVM header with a BDRA
#vgextend vg00 /dev/dsk/c2t6d0
Include the disk into vg00
#mkboot /dev/dsk/c2t6d0
Created a LIF on the new disk and add the LIF Filesystem to the BDRA
#lvextend -m 1 /dev/vg00/lvol1 /dev/dsk/c2t6d0
#lvextend -m 1 /dev/vg00/lvol2 /dev/dsk/c2t6d0
#lvextend -m 1 /dev/vg00/lvol3 /dev/dsk/c2t6d0
.
.
.
.
etc
#lvlnboot -R /dev/vg00
Ensure BDRA is synchronized
#lvlnboot -v /dev/vg00
#mkboot -a "hpux" -lq /dev/rdsk/c2t6d0

Is This Answer Correct ?    0 Yes 0 No

Post New Answer

More Unix General Interview Questions

What are the links and symbolic links in a unix file system?

0 Answers  


What do you mean by unix operating system?

0 Answers  


finding the presence of a word in a list of 'n' files (pattern matching)

2 Answers   TCS,


What do you understand by the term filters?

0 Answers  


Explain how and when a DNS request is solved when a user tries to surf to the site www.abcdeg.in .Assume the user machine uses a local name server and sits on another network other than www.abcdef.in.

1 Answers  






Differentiate between paging and swapping?

0 Answers  


What is the best free unix based os?

0 Answers  


Is it possible to create new a file system in UNIX?

0 Answers  


What are system variables in unix?

0 Answers  


What is delayed write in unix?

0 Answers  


What are conditions for a machine to support Demand Paging?

0 Answers  


Is unix portable?

0 Answers  


Categories